読者です 読者をやめる 読者になる 読者になる

ねっとぱんだ

Webデザイン、プログラミングの勉強ブログ。

【jQuery】バージョンの差異を解決 jQuery Migrate


引用元
jQuery Migrate pluginを使ってみる。 | バシャログ。

  1. 廃止されたAPIを使おうとしたり、挙動が変わった機能を使おうとした際に、ブラウザのコンソールに警告を出力する。

+廃止されたAPIを復元する

例えばtoggleメソッドは1.9では排除されているが
jQuery Migrate 1.2.1で復活できる。

<script src="http://code.jquery.com/jquery-1.11.3.min.js"></script>
<script src="http://code.jquery.com/jquery-migrate-1.2.1.min.js">

公式サイトのjQueryMigrate
Migrate | Search Results | Official jQuery Blog